import Foundation
let pattern = #"[^0-9A-Za-z\n]|[a-zA-Z]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
MA0244891-D
--> MA0244891
MA0244891
--> MA0244891
MA0244891D
--> MA0244891
0244891D
--> 0244891
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)