const regex = /[^0-9A-Za-z\n]|[a-zA-Z]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^0-9A-Za-z\\n]|[a-zA-Z]+$', 'gm')
const str = `MA0244891-D
--> MA0244891
MA0244891
--> MA0244891
MA0244891D
--> MA0244891
0244891D
--> 0244891`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);