using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\W*(\w+)\W+(\w+).*";
string substitution = @"\1 \2";
string input = @"Hi, I am Harry Potter";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}