$re = '/^\W*(\w+)\W+(\w+).*/m';
$str = 'Hi, I am Harry Potter';
$subst = "\1 \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;