import re
regex = re.compile(r"^\W*(\w+)\W+(\w+).*", flags=re.MULTILINE)
test_str = "Hi, I am Harry Potter"
subst = "\\1 \\2"
result = regex.sub(subst, test_str)
if result:
print(result)