re = /^\W*(\w+)\W+(\w+).*/m
str = 'Hi, I am Harry Potter'
subst = '\\1 \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result