package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\W*(\w+)\W+(\w+).*`)
var str = `Hi, I am Harry Potter`
var substitution = "\1 \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}