const regex = /^\W*(\w+)\W+(\w+).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\W*(\\w+)\\W+(\\w+).*', 'gm')
const str = `Hi, I am Harry Potter`;
const subst = `\1 \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);