using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"("")(\S.*?\S)("")";
string substitution = @"«$2»";
string input = @"""el taller del traductor""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}