import re
regex = re.compile(r"(\")(\S.*?\S)(\")")
test_str = "\"el taller del traductor\""
subst = "«$2»"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)