import Foundation
let pattern = #"(")(\S.*?\S)(")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""el taller del traductor""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"«$2»"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}