use strict;
my $str = '"el taller del traductor"';
my $regex = qr/(")(\S.*?\S)(")/p;
my $subst = '«$2»';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";