$re = '/(")(\S.*?\S)(")/';
$str = '"el taller del traductor"';
$subst = "«$2»";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;