#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=CLD:\s).*"
Local $sString = "FF YBRFYMYX YMMCYMYX YSRFYMYX" & @CRLF & _
"061702 YBBNITAS" & @CRLF & _
"ATIS YBBN H 061702" & @CRLF & _
"RWY: 14" & @CRLF & _
"OPR INFO: RUNWAY 19 LEFT AVAILABLE AS PUR NOTAM. MULTIPLE" & @CRLF & _
"TAXIWAY CLOSURES REFER NOTAMS. " & @CRLF & _
"WND: 200/6" & @CRLF & _
"VIS: GREATER THAN 10 KM " & @CRLF & _
"CLD: FEW040" & @CRLF & _
"+ TMP: 13" & @CRLF & _
"+ QNH: 1016"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")