import Foundation
let pattern = #"(?<=CLD:\s).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
FF YBRFYMYX YMMCYMYX YSRFYMYX
061702 YBBNITAS
ATIS YBBN H 061702
RWY: 14
OPR INFO: RUNWAY 19 LEFT AVAILABLE AS PUR NOTAM. MULTIPLE
TAXIWAY CLOSURES REFER NOTAMS.
WND: 200/6
VIS: GREATER THAN 10 KM
CLD: FEW040
+ TMP: 13
+ QNH: 1016
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)