import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=CLD:\\s).*";
final String string = "FF YBRFYMYX YMMCYMYX YSRFYMYX\n"
+ "061702 YBBNITAS\n"
+ "ATIS YBBN H 061702\n"
+ "RWY: 14\n"
+ "OPR INFO: RUNWAY 19 LEFT AVAILABLE AS PUR NOTAM. MULTIPLE\n"
+ "TAXIWAY CLOSURES REFER NOTAMS. \n"
+ "WND: 200/6\n"
+ "VIS: GREATER THAN 10 KM \n"
+ "CLD: FEW040\n"
+ "+ TMP: 13\n"
+ "+ QNH: 1016";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}