$re = '/(?<=CLD:\s).*/m';
$str = 'FF YBRFYMYX YMMCYMYX YSRFYMYX
061702 YBBNITAS
ATIS YBBN H 061702
RWY: 14
OPR INFO: RUNWAY 19 LEFT AVAILABLE AS PUR NOTAM. MULTIPLE
TAXIWAY CLOSURES REFER NOTAMS.
WND: 200/6
VIS: GREATER THAN 10 KM
CLD: FEW040
+ TMP: 13
+ QNH: 1016';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);