import re
regex = re.compile(r"(?<=CLD:\s).*", flags=re.MULTILINE)
test_str = ("FF YBRFYMYX YMMCYMYX YSRFYMYX\n"
"061702 YBBNITAS\n"
"ATIS YBBN H 061702\n"
"RWY: 14\n"
"OPR INFO: RUNWAY 19 LEFT AVAILABLE AS PUR NOTAM. MULTIPLE\n"
"TAXIWAY CLOSURES REFER NOTAMS. \n"
"WND: 200/6\n"
"VIS: GREATER THAN 10 KM \n"
"CLD: FEW040\n"
"+ TMP: 13\n"
"+ QNH: 1016")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")