#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(\s*.*?\w*\h*,(*SKIP)(*F)|(?|(")[^"\\]*(?:\\.[^"\\]*)*"|(')[^'\\]*(?:\\.[^'\\]*)*')"
Local $sString = "a="abc";" & @CRLF & _
"b='def';" & @CRLF & _
"c="That's the way to do it";" & @CRLF & _
"d='That\'s the way "to do it"';" & @CRLF & _
"e=e.replace(//g, '"');" & @CRLF & _
"f=f.replace(/'/g, '"'); " & @CRLF & _
"g=g.replace(/\'/g, '"');" & @CRLF & _
"h=h.replace(/\"/g, '\"');" & @CRLF & _
"i=i.replace(/\\"/g, '\\"');"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")