// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\(\s*.*?\w*\h*,(*SKIP)(*F)|(?|(")[^"\\]*(?:\\.[^"\\]*)*"|(')[^'\\]*(?:\\.[^'\\]*)*')"#).unwrap();
let string = "a=\"abc\";
b='def';
c=\"That's the way to do it\";
d='That\\'s the way \"to do it\"';
e=e.replace(//g, '\"');
f=f.replace(/'/g, '\"');
g=g.replace(/\\'/g, '\"');
h=h.replace(/\\\"/g, '\\\"');
i=i.replace(/\\\\\"/g, '\\\\\"');";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}