import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\s*.*?\\w*\\h*,(*SKIP)(*F)|(?|(\")[^\"\\\\]*(?:\\\\.[^\"\\\\]*)*\"|(')[^'\\\\]*(?:\\\\.[^'\\\\]*)*')";
final String string = "a=\"abc\";\n"
+ "b='def';\n"
+ "c=\"That's the way to do it\";\n"
+ "d='That\\'s the way \"to do it\"';\n"
+ "e=e.replace(//g, '\"');\n"
+ "f=f.replace(/'/g, '\"'); \n"
+ "g=g.replace(/\\'/g, '\"');\n"
+ "h=h.replace(/\\\"/g, '\\\"');\n"
+ "i=i.replace(/\\\\\"/g, '\\\\\"');";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}