import re
regex = re.compile(r"\(\s*.*?\w*\h*,(*SKIP)(*F)|(?|(\")[^\"\\]*(?:\\.[^\"\\]*)*\"|(')[^'\\]*(?:\\.[^'\\]*)*')", flags=re.MULTILINE)
test_str = ("a=\"abc\";\n"
"b='def';\n"
"c=\"That's the way to do it\";\n"
"d='That\\'s the way \"to do it\"';\n"
"e=e.replace(//g, '\"');\n"
"f=f.replace(/'/g, '\"'); \n"
"g=g.replace(/\\'/g, '\"');\n"
"h=h.replace(/\\\"/g, '\\\"');\n"
"i=i.replace(/\\\\\"/g, '\\\\\"');")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")