package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(\s*.*?\w*\h*,(*SKIP)(*F)|(?|(")[^"\\]*(?:\\.[^"\\]*)*"|(')[^'\\]*(?:\\.[^'\\]*)*')`)
var str = `a="abc";
b='def';
c="That's the way to do it";
d='That\'s the way "to do it"';
e=e.replace(//g, '"');
f=f.replace(/'/g, '"');
g=g.replace(/\'/g, '"');
h=h.replace(/\"/g, '\"');
i=i.replace(/\\"/g, '\\"');`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}