const regex = /\(\s*.*?\w*\h*,(*SKIP)(*F)|(?|(")[^"\\]*(?:\\.[^"\\]*)*"|(')[^'\\]*(?:\\.[^'\\]*)*')/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(\\s*.*?\\w*\\h*,(*SKIP)(*F)|(?|(")[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|(\')[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\')', 'gm')
const str = `a="abc";
b='def';
c="That's the way to do it";
d='That\\'s the way "to do it"';
e=e.replace(//g, '"');
f=f.replace(/'/g, '"');
g=g.replace(/\\'/g, '"');
h=h.replace(/\\"/g, '\\"');
i=i.replace(/\\\\"/g, '\\\\"');`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}