#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]+(?:-[0-9]+)?(,[0-9]+(?:-[0-9]+)?)*$"
Local $sString = "34" & @CRLF & _
"38-30" & @CRLF & _
"100,25-30" & @CRLF & _
"4-5,5,1-5" & @CRLF & _
"a-z" & @CRLF & _
"1,2,5-" & @CRLF & _
"123,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")