import re
regex = re.compile(r"^[0-9]+(?:-[0-9]+)?(,[0-9]+(?:-[0-9]+)?)*$", flags=re.MULTILINE)
test_str = ("34\n"
"38-30\n"
"100,25-30\n"
"4-5,5,1-5\n"
"a-z\n"
"1,2,5-\n"
"123,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")