import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]+(?:-[0-9]+)?(,[0-9]+(?:-[0-9]+)?)*$";
final String string = "34\n"
+ "38-30\n"
+ "100,25-30\n"
+ "4-5,5,1-5\n"
+ "a-z\n"
+ "1,2,5-\n"
+ "123,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}