// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]+(?:-[0-9]+)?(,[0-9]+(?:-[0-9]+)?)*$").unwrap();
let string = "34
38-30
100,25-30
4-5,5,1-5
a-z
1,2,5-
123,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}