using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9]+(?:-[0-9]+)?(,[0-9]+(?:-[0-9]+)?)*$";
string input = @"34
38-30
100,25-30
4-5,5,1-5
a-z
1,2,5-
123,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}