$re = '/^[0-9]+(?:-[0-9]+)?(,[0-9]+(?:-[0-9]+)?)*$/m';
$str = '34
38-30
100,25-30
4-5,5,1-5
a-z
1,2,5-
123,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);