package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]+(?:-[0-9]+)?(,[0-9]+(?:-[0-9]+)?)*$`)
var str = `34
38-30
100,25-30
4-5,5,1-5
a-z
1,2,5-
123,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}