#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d+).*?(?:([A-Z])\.\s*)?([A-Z].*)([A-Z]\S+) - (.*)"
Local $sString = "12thJ. JacobsLV - RB" & @CRLF & _
"" & @CRLF & _
"13thS. DiggsBuf - WR" & @CRLF & _
"" & @CRLF & _
"14thD. AdamsLV - WR" & @CRLF & _
"" & @CRLF & _
"19thA. St. BrownDet - WR" & @CRLF & _
"" & @CRLF & _
"97thJ. Smith-NjigbaSea - WR" & @CRLF & _
"" & @CRLF & _
"120thMiamiMia - DEF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")