import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+).*?(?:([A-Z])\\.\\s*)?([A-Z].*)([A-Z]\\S+) - (.*)";
final String string = "12thJ. JacobsLV - RB\n\n"
+ "13thS. DiggsBuf - WR\n\n"
+ "14thD. AdamsLV - WR\n\n"
+ "19thA. St. BrownDet - WR\n\n"
+ "97thJ. Smith-NjigbaSea - WR\n\n"
+ "120thMiamiMia - DEF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}