using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+).*?(?:([A-Z])\.\s*)?([A-Z].*)([A-Z]\S+) - (.*)";
string input = @"12thJ. JacobsLV - RB
13thS. DiggsBuf - WR
14thD. AdamsLV - WR
19thA. St. BrownDet - WR
97thJ. Smith-NjigbaSea - WR
120thMiamiMia - DEF";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}