import Foundation
let pattern = #"^(\d+).*?(?:([A-Z])\.\s*)?([A-Z].*)([A-Z]\S+) - (.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
12thJ. JacobsLV - RB
13thS. DiggsBuf - WR
14thD. AdamsLV - WR
19thA. St. BrownDet - WR
97thJ. Smith-NjigbaSea - WR
120thMiamiMia - DEF
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)