// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+).*?(?:([A-Z])\.\s*)?([A-Z].*)([A-Z]\S+) - (.*)").unwrap();
let string = "12thJ. JacobsLV - RB
13thS. DiggsBuf - WR
14thD. AdamsLV - WR
19thA. St. BrownDet - WR
97thJ. Smith-NjigbaSea - WR
120thMiamiMia - DEF";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}