$re = '/^(\d+).*?(?:([A-Z])\.\s*)?([A-Z].*)([A-Z]\S+) - (.*)/m';
$str = '12thJ. JacobsLV - RB
13thS. DiggsBuf - WR
14thD. AdamsLV - WR
19thA. St. BrownDet - WR
97thJ. Smith-NjigbaSea - WR
120thMiamiMia - DEF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);