const regex = new RegExp('^(\\d+).*?(?:([A-Z])\\.\\s*)?([A-Z].*)([A-Z]\\S+) - (.*)', 'gm')
const str = `12thJ. JacobsLV - RB
13thS. DiggsBuf - WR
14thD. AdamsLV - WR
19thA. St. BrownDet - WR
97thJ. Smith-NjigbaSea - WR
120thMiamiMia - DEF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}