# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Z]+\s+\d+)\s+and\s+\(([A-Z]+\s+\d+)\s+or\s+([A-Z]+\s+\d+)\)/ X\n \/\\\n \1 ()\n \/ - \\\n \2 \3/gm;t' <<< "SU 3180 and (CMG 3200 or SU 3210)"