// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Z]+\s+\d+)\s+and\s+\(([A-Z]+\s+\d+)\s+or\s+([A-Z]+\s+\d+)\)").unwrap();
let string = "SU 3180 and (CMG 3200 or SU 3210)";
let substitution = " X\\n /\\\\\\n \\1 ()\\n / - \\\\\\n \\2 \\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}