import Foundation
let pattern = #"([A-Z]+\s+\d+)\s+and\s+\(([A-Z]+\s+\d+)\s+or\s+([A-Z]+\s+\d+)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"SU 3180 and (CMG 3200 or SU 3210)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" X\n /\\\n \1 ()\n / - \\\n \2 \3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)