package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z]+\s+\d+)\s+and\s+\(([A-Z]+\s+\d+)\s+or\s+([A-Z]+\s+\d+)\)`)
var str = `SU 3180 and (CMG 3200 or SU 3210)`
var substitution = " X\n /\\\n \1 ()\n / - \\\n \2 \3"
fmt.Println(re.ReplaceAllString(str, substitution))
}