import re
regex = re.compile(r"([A-Z]+\s+\d+)\s+and\s+\(([A-Z]+\s+\d+)\s+or\s+([A-Z]+\s+\d+)\)", flags=re.MULTILINE)
test_str = "SU 3180 and (CMG 3200 or SU 3210)"
subst = " X\\n /\\\\\\n \\1 ()\\n / - \\\\\\n \\2 \\3"
result = regex.sub(subst, test_str)
if result:
print(result)