$re = '/([A-Z]+\s+\d+)\s+and\s+\(([A-Z]+\s+\d+)\s+or\s+([A-Z]+\s+\d+)\)/m';
$str = 'SU 3180 and (CMG 3200 or SU 3210)';
$subst = " X\n /\\\n \1 ()\n / - \\\n \2 \3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;