use strict;
my $str = 'SU 3180 and (CMG 3200 or SU 3210)';
my $regex = qr/([A-Z]+\s+\d+)\s+and\s+\(([A-Z]+\s+\d+)\s+or\s+([A-Z]+\s+\d+)\)/mp;
my $subst = ' X\\n /\\\\\\n \\1 ()\\n / - \\\\\\n \\2 \\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";