#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d{7}[\da-zA-Z]\d{0,2}|\d{1,7})$"
Local $sString = "1" & @CRLF & _
"123" & @CRLF & _
"1234567890" & @CRLF & _
"1234567a" & @CRLF & _
"" & @CRLF & _
"1a" & @CRLF & _
"123456789a" & @CRLF & _
"12345678901"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")