// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d{7}[\da-zA-Z]\d{0,2}|\d{1,7})$").unwrap();
let string = "1
123
1234567890
1234567a
1a
123456789a
12345678901";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}