$re = '/^(?:\d{7}[\da-zA-Z]\d{0,2}|\d{1,7})$/m';
$str = '1
123
1234567890
1234567a
1a
123456789a
12345678901';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);