const regex = /^(?:\d{7}[\da-zA-Z]\d{0,2}|\d{1,7})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d{7}[\\da-zA-Z]\\d{0,2}|\\d{1,7})$', 'gm')
const str = `1
123
1234567890
1234567a
1a
123456789a
12345678901`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}