re = /^(?:\d{7}[\da-zA-Z]\d{0,2}|\d{1,7})$/m
str = '1
123
1234567890
1234567a
1a
123456789a
12345678901'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end